Создание сайта на WordPress, версии PHP, MySQL — требования к хостингу

Перед установкой релиза WordPress версии 4.5, взятой с wordpress.org, прочитал о минимальных требованиях к хостингу (серверу):

To run WordPress we recommend your host supports:
PHP version 5.6 or greater
MySQL version 5.6 or greater OR MariaDB version 10.0 or greater

Т.е. требуется наличие версии пхп не ниже 5.6 и майскюель не ниже 5.6.

Поинтересовался у своего хостера IHC.ru в чате поддержки наличием соответствующих версий. Оказалось, что в обоих случаях версии ниже требуемых.

MySQL, к сожалению, пока поменять никак нельзя, а вот подключить нужную версию PHP оказалось довольно просто:

Данная инструкция подходит только для тарифов виртуального хостинга с панелью cPanel и ISP.

По умолчанию на тарифах C-panel установлен PHP 5.3.

Изменить версию PHP можно через файл .htaccess , следует добавить только строчку с нужной версией PHP.

#PHP 5.2

AddHandler application/x-httpd-php52 .php

#PHP 5.3

AddHandler application/x-httpd-php5 .php

#PHP 5.4

AddHandler application/x-httpd-php54 .php

#PHP 5.5

AddHandler application/x-httpd-php55 .php

#PHP 5.6

AddHandler application/x-httpd-php56 .php

#PHP 7.0

AddHandler application/x-httpd-php7 .php

Примечание: Если после изменения версии на PHP 5.4 получаете ошибку Request timeout, то, вероятнее всего, Вам нужно удалить register_globals и register_long_arrays из php.ini . register_globals и register_long_arrays была УДАЛЕНА в версии PHP 5.4.

Подключил PHP 5.6, а MySQL осталась 5-ой версии.

Создал необходимую базу данных, запустил вордпресс и, судя по всему, полет нормальный — все работает.

Ну, что же?

Привет, мир! :)

Понравилась статья? Поделиться с друзьями:
Добавить комментарий

;-) :| :x :twisted: :smile: :shock: :sad: :roll: :razz: :oops: :o :mrgreen: :lol: :idea: :grin: :evil: :cry: :cool: :arrow: :???: :?: :!: